Saturday, January 28, 2023
Home iOS Development ios – Can’t run “pod install” on M1

ios – Can’t run “pod install” on M1

0
64

[ad_1]

ios – Can’t run “pod install” on M1 – Stack Overflow
















Asked

Viewed
14 times

I started to work on porting a small iOS project I had on an old Mac (2014 model) to an M1 that I bought just a few months ago.
After installing the last version of Xcode as well as cocoapods.

I ran “pod init” an edited the Podfile as usual.

Then running “pod install” brought some problems as can be seen below.

me@My-MacBook-Air APP % pod install
Analyzing dependencies
Adding spec repo `trunk` with CDN `https://cdn.cocoapods.org/`
/Library/Ruby/Gems/2.6.0/gems/ffi-1.15.5/lib/ffi/library.rb:275: [BUG] Bus Error at 0x00000001044dc000
ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:                    
     * ~/Library/Logs/DiagnosticReports                                     
     * /Library/Logs/DiagnosticReports                                      
   for more details.                                                        
Don't forget to include the above Crash Report log file in bug reports.     

-- Control frame information -----------------------------------------------
c:0050 p:---- s:0320 e:000319 CFUNC  :attach
c:0049 p:0258 s:0314 e:000313 METHOD /Library/Ruby/Gems/2.6.0/gems/ffi-1.15.5/lib/ffi/library.rb:275
c:0048 p:0050 s:0294 e:000293 CLASS  /Library/Ruby/Gems/2.6.0/gems/ethon-0.15.0/lib/ethon/libc.rb:17
c:0047 p:0007 s:0291 e:000290 CLASS  /Library/Ruby/Gems/2.6.0/gems/ethon-0.15.0/lib/ethon/libc.rb:7
c:0046 p:0007 s:0288 e:000287 TOP    /Library/Ruby/Gems/2.6.0/gems/ethon-0.15.0/lib/ethon/libc.rb:2 [FINISH]
c:0045 p:---- s:0285 e:000284 CFUNC  :require
c:0044 p:0110 s:0280 e:000279 METHOD /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/   kernel_require.rb:54
c:0043 p:0042 s:0268 e:000267 TOP    /Library/Ruby/Gems/2.6.0/gems/ethon-0.15.0/lib/ethon.rb:15 [FINISH]
c:0042 p:---- s:0265 e:000264 CFUNC  :require
c:0041 p:0110 s:0260 e:000259 METHOD /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/   kernel_require.rb:54
c:0040 p:0013 s:0248 e:000247 TOP    /Library/Ruby/Gems/2.6.0/gems/typhoeus-1.4.0/lib/typhoeus.rb:2 [FINISH]
c:0039 p:---- s:0245 e:000244 CFUNC  :require
c:0038 p:0110 s:0240 e:000239 METHOD /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/core_ext/   kernel_require.rb:54
c:0037 p:0006 s:0228 e:000227 METHOD /Library/Ruby/Gems/2.6.0/gems/cocoapods-core-1.11.3/lib/cocoapods-core/cdn_source.rb:440
c:0036 p:0045 s:0220 e:000219 METHOD /Library/Ruby/Gems/2.6.0/gems/cocoapods-core-1.11.3/lib/cocoapods-core/cdn_source.rb:372
c:0035 p:0318 s:0209 e:000208 METHOD /Library/Ruby/Gems/2.6.0/gems/cocoapods-core-1.11.3/lib/cocoapods-core/cdn_source.rb:365
.....
c:0004 p:0378 s:0019 e:000018 TOP    /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/bin/pod:55 [FINISH]
c:0003 p:---- s:0013 e:000012 CFUNC  :load
c:0002 p:0109 s:0008 E:001b70 EVAL   /usr/local/bin/pod:23 [FINISH]
c:0001 p:0000 s:0003 E:0014a0 (none) [FINISH]

-- Ruby level backtrace information ----------------------------------------
/usr/local/bin/pod:23:in `<main>'
/usr/local/bin/pod:23:in `load'
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/bin/pod:55:in `<top (required)>'
/Library/Ruby/Gems/2.6.0/gems/cocoapods-1.11.3/lib/cocoapods/command.rb:52:in `run'
.....

Has anybody got similar issues in the past and found a solution?

1

lang-swift

 

[ad_2]

Channel969