ios – Expo App construct failing I am pondering its file permisions

0
59


I’ve this app that i inherited however when i attempt to construct utilizing eas construct --profile manufacturing --local -p ios; i get construct failing

I do know this may sound bizarre however i feel its one thing todo with app permissions, i feel this added @ on the finish is messing up construct however I am not 100% certain.

On the left is the working app however on the correct is the damaged, even tho i used all of the code from working app.

enter image description here

[RUN_FASTLANE] › Compiling MyCustomApp » AppDelegate.mm
[RUN_FASTLANE] › Linking   MyCustomApp » MyCustomApp
[RUN_FASTLANE] ⚠️  ld: ignoring duplicate libraries: '-lc++'
[RUN_FASTLANE] › Producing debug MyCustomApp » MyCustomApp.app.dSYM
[RUN_FASTLANE] › Executing MyCustomApp » Bundle React Native code and pictures
[RUN_FASTLANE]     Bundler cache is empty, rebuilding (this will take a minute)
[RUN_FASTLANE] ⚠️  Script has ambiguous dependencies inflicting it to run on each construct.
   To repair, go to: Xcode » MyCustomApp/MyCustomApp » Construct Phases » '[CP-User] [RNFB] Core Configuration'
   Both: Uncheck "Primarily based on dependency evaluation", or choose output information to set off the script

[RUN_FASTLANE] ▸ ** ARCHIVE FAILED **
[RUN_FASTLANE] ▸ The next construct instructions failed:
[RUN_FASTLANE] ▸        PhaseScriptExecution Bundle React Native code and pictures /Customers/marius/Library/Developer/Xcode/DerivedData/MyCustomApp-hjtsbldyqmjgcyatgghwyadjeyjb/Construct/Intermediates.noindex/ArchiveIntermediates/MyCustomApp/IntermediateBuildFilesPath/MyCustomApp.construct/Launch-iphoneos/MyCustomApp.construct/Script-00DD1BFF1BD5951E006B06BC.sh (in goal 'MyCustomApp' from challenge 'MyCustomApp')
[RUN_FASTLANE] ▸ (1 failure)
[RUN_FASTLANE] ** ARCHIVE FAILED **
[RUN_FASTLANE]
[RUN_FASTLANE]
[RUN_FASTLANE] The next construct instructions failed:
[RUN_FASTLANE]  PhaseScriptExecution Bundle React Native code and pictures /Customers/marius/Library/Developer/Xcode/DerivedData/MyCustomApp-hjtsbldyqmjgcyatgghwyadjeyjb/Construct/Intermediates.noindex/ArchiveIntermediates/MyCustomApp/IntermediateBuildFilesPath/MyCustomApp.construct/Launch-iphoneos/MyCustomApp.construct/Script-00DD1BFF1BD5951E006B06BC.sh (in goal 'MyCustomApp' from challenge 'MyCustomApp')
[RUN_FASTLANE] (1 failure)
[RUN_FASTLANE] Exit standing: 65
[RUN_FASTLANE]
[RUN_FASTLANE] +---------------------------------------+
[RUN_FASTLANE] |           Construct surroundings           |
[RUN_FASTLANE] +-------------+-------------------------+
[RUN_FASTLANE] | xcode_path  | /Functions/Xcode.app |
[RUN_FASTLANE] | gym_version | 2.221.1                 |
[RUN_FASTLANE] | sdk         | iPhoneOS17.5.sdk        |
[RUN_FASTLANE] +-------------+-------------------------+
[RUN_FASTLANE]
[RUN_FASTLANE] Appears to be like like fastlane ran right into a construct/archive error together with your challenge
[RUN_FASTLANE] It is exhausting to inform what's inflicting the error, so we wrote some guides on how
[RUN_FASTLANE] to troubleshoot construct and signing points: https://docs.fastlane.instruments/codesigning/getting-started/
[RUN_FASTLANE] Earlier than submitting a problem on GitHub, please comply with the information above and make
[RUN_FASTLANE] certain your challenge is ready up appropriately.
[RUN_FASTLANE] fastlane makes use of `xcodebuild` instructions to generate your binary, you'll be able to see the
[RUN_FASTLANE] the complete instructions printed out in yellow within the above log.
[RUN_FASTLANE] Be certain that to examine the output above, as normally you may discover extra error data there
[RUN_FASTLANE] [!] Error constructing the appliance - see the log above
[RUN_FASTLANE] Error: The "Run fastlane" step failed with an unknown error. Discuss with "Xcode Logs" beneath for added, extra detailed logs.
[CLEAN_UP_CREDENTIALS] Destroying keychain - /var/folders/nq/9t468y2j4bn2nmqfswkm0kcw0000gn/T/eas-build-cc95c4c9-c1a9-49b2-893a-ca170a88768d.keychain
[CLEAN_UP_CREDENTIALS] Eradicating provisioning profile

Construct failed
The "Run fastlane" step failed with an unknown error. Discuss with "Xcode Logs" beneath for added, extra detailed logs.
npx exited with non-zero code: 1
    Error: construct command failed.