Cocoapods Segmentation Fault When Adding ‘google_sign_in’ Package to Flutter App (iOS Variant)

0
117


I can’t compile my Flutter App (iOS variant) when I added the package google_sign_in. At first, the symptom had to do with f f i pods (whatever they are). As per the resulting error message, I uninstalled ffi and re-installed it with the –enable-libffi-alloc switch as follows:



sudo gem uninstall ffi && sudo gem install ffi -- --enable-libffi-alloc

Now, I’m getting the following error:

Error output from CocoaPods:

/Library/Ruby/Gems/2.6.0/gems/ethon-0.12.0/lib/ethon/curls/infos.rb:127: [BUG] Segmentation fault at 0xffffffffffffffa8

ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]

Ive been looking for solutions to the above and the consensus seems to point to some pods incompatibility with my M1 processor. Ive been trying lots of suggestions for the past day, all to no avail, and I’m at wits end. Im hoping that somebody out there can help.



My environment is as follows:



Box: MacBook Air M1
    
OS: Monterey 12.2
    
Flutter Vers: 3.3.8
    
google_sign_in package vers: 5.4.2
    
    

Thanks in advance for any suggestions.



/Jose